1032 Sharing (25 分)

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

在這裏插入圖片描述

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

tips

提交次數 分數 通過樣例個數 tips
1 12 3 輸出"%05d"
2 14 4 注意-1的輸出與上不同
3 25 all 修改了traval函數
  1. 一開始的思路是第一遍遍歷第一個address,vis記錄訪問過的節點;第二遍遍歷第二個address,找到第一個之前已訪問的節點即爲答案
  2. 很明顯上面的思路有缺陷:並不是第一個共同的letter的地址就是我們要找的答案,比如owingloading,第一個相同字母o,而其後面的字母並不完全相同
  3. 正確的思路應該是:找到第一個相同地址後,比對後面的每一個地址是否對應相同
  4. 而我只是找到第一個相同地址後,判斷後面的所有地址是否已經訪問過,這樣也完全通過了測試T_T
  5. 所以測試用例並沒有設置那麼難,即使按照第一個有缺陷的思路也能拿到14分,因此不要把PAT想得太複雜,但是想要拿到滿分還是要對待問題儘量考慮全面

code

#include <bits/stdc++.h>
using namespace std;

const int maxn = 100000;

struct node
{
    char data;
    int next;
}report[maxn];

bool vis[maxn] = {false};
int ans = -1;

int travel(int adr, bool flag)
{
   // printf("adr=%05d\n",adr);
    if(adr == -1) return ans;
    if(vis[adr] == 1 && !flag){
        ans = adr;
        flag = true; //已經找到第一個相同的地址了
    }
    if(flag && !vis[adr]){
        flag = false;
        ans = -1;
    }
    vis[adr] = 1;
    travel(report[adr].next, flag);
}



int main()
{
    int adr1,adr2,n;
    scanf("%d%d%d",&adr1,&adr2,&n);
    for(int i = 0; i < n; i++){
        int ad,data,next;
        scanf("%d %c %d",&ad,&data,&next);
        report[ad].data = data;
        report[ad].next = next;
        //printf("%d %c %d\n",ad,data,next);
    }
    travel(adr1, false);
    int ans = travel(adr2, false);
    if(ans >= 0) printf("%05d",ans); //注意格式
    else printf("%d",ans); //區分-1的格式
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章