HDU 3336 Count the strings(KMP+DP)

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
Sample Input
1
4
abab
Sample Output
6

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#define maxn 1000010
using namespace std;
int nex[maxn];
int ans[maxn];
int dp[maxn];
char s1[maxn];
char s2[maxn];
const int mod=10007;
void getNext(char* P, int* f)
{
    int m = strlen(P);
    f[0] = 0;
    f[1] = 0;
    for(int i = 1; i < m; i++)
    {
        int j = f[i];
        while(j && P[i] != P[j])
        {
            j = f[j];
        }
        f[i + 1]=P[i]==P[j]?j+1:0;
    }
}

int kmp(char* T, char*P, int*f)
{
    int n = strlen(T), m = strlen(P);
    int j = 0;
    int ans=0;
    for(int i = 0; i < n; i++)
    {
        while(j && P[j] != T[i])
        {
            j = f[j];
        }
        if(P[j] == T[i])
        {
            j++;
        }
        if(j == m)
        {
            ans++;
            j=0;
        }
    }
    return ans;
}
int main()
{

    int a;
    int n;
    int m;
    int ca=1;
    int  t;

    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d%s",&n,s1);
        getNext(s1,nex);
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            dp[i]=(dp[nex[i]]+1)%mod;
            ans=(ans+dp[i])%mod;
        }
        printf("%d\n",ans);

    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章