QS Network--prim算法的應用

QS Network
Time Limit:1s Memory limit:32M
Accepted Submit:232 Total Submit:750

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:

 


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

 


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1 3 10 20 30 0 100 200 100 0 300 200 300 0


Sample Output

370
分析:prim算法是求最小生成樹,是無向圖,還要注意的是如果兩點之間沒有直接通路的話,這兩點是可以直接相通的! 
code:
#include<stdio.h> 
#define INF 32767 
struct MGraph{ 
int n; 
int edges[1000][1000]; 
};
 void CreatMGraph(MGraph &g) 
{ int i,j; int a[1000]; 
scanf("%d%*c",&g.n);
 for(i=0;i<g.n;i++) scanf("%d%*c",&a[i]); 
for(i=0;i<g.n;i++) { for(j=0;j<g.n;j++) scanf("%d%*c",&g.edges[i][j]); } 
for(i=0;i<g.n;i++) { for(j=0;j<g.n;j++) { if(i!=j) g.edges[i][j]+=a[i]+a[j]; } } 
} 
void prim(MGraph &g) 
{ int lowcost[1000]; int min; int sum=0; 
int closest[INF],i,j,k; 
for(i=0;i<g.n;i++) {
 lowcost[i]=g.edges[0][i]; 
closest[i]=0; 
} 
lowcost[0]=0;
 for(i=1;i<g.n;i++) {
 min=INF; //特別注意的地方 
for(j=0;j<g.n;j++) if(lowcost[j]!=0&&lowcost[j]<min) 
{ min=lowcost[j]; k=j; } sum+=min; lowcost[k]=0; 
for(j=0;j<g.n;j++) 
{ if(g.edges[k][j]!=0&&g.edges[k][j]<lowcost[j]) 
{ 
lowcost[j]=g.edges[k][j]; closest[j]=k; } 
} 
} 
printf("%d/n",sum); 
} int main() 
{ register int i; int m,n; 
scanf("%d%*c",&m); 
for(i=0;i<m;i++) 
{ MGraph g; CreatMGraph(g); prim(g); 
}
 return 0; 
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章