usaco2.14Hamming Codes

Hamming Codes
Rob Kolstad

Given N, B, and D: Find a set of N codewords (1 <= N <= 64), each of length B bits (1 <= B <= 8), such that each of the codewords is at least Hamming distance of D (1 <= D <= 7) away from each of the other codewords. The Hamming distance between a pair of codewords is the number of binary bits that differ in their binary notation. Consider the two codewords 0x554 and 0x234 and their differences (0x554 means the hexadecimal number with hex digits 5, 5, and 4):

        0x554 = 0101 0101 0100
        0x234 = 0010 0011 0100
Bit differences: xxx  xx

Since five bits were different, the Hamming distance is 5.

PROGRAM NAME: hamming

INPUT FORMAT

N, B, D on a single line

SAMPLE INPUT (file hamming.in)

16 7 3

OUTPUT FORMAT

N codewords, sorted, in decimal, ten per line. In the case of multiple solutions, your program should output the solution which, if interpreted as a base 2^B integer, would have the least value.

SAMPLE OUTPUT (file hamming.out)

0 7 25 30 42 45 51 52 75 76
82 85 97 102 120 127

枚舉

/*
    ID: your_id_here
    PROG: hamming
    LANG: C++
*/
#include <iostream>
#include<cstdio>
#include<cstring>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int di[100],b,n,d;
int judge(int x)
{
    int i,k=0;
    for(i = 0 ; i < b ; i++)
    {
        if((1<<i)&x)
        {
            k++;
        }
    }
    if(k>=d)
    return 1;
    return 0;
}
int main()
{
    freopen("hamming.in","r",stdin);
    freopen("hamming.out","w",stdout);
    int i,j,g=1;
    di[1] = 0;
    cin>>n>>b>>d;
    for(i = 1; i <= (1<<b); i++)
    {
        for(j = 1 ; j <= g ; j++)
        {
            if(!judge(di[j]^i))
                break;
        }
        if(j==g+1)
        {
            g++;
            di[g] = i;
        }
        if(g==n)
        break;
    }
    for(i = 1; i <= n ; i++)
    {
        if(i%10!=1)
        cout<<" ";
        cout<<di[i];
        if(i%10==0)
           puts("");
    }
    if(n%10!=0)
    puts("");
    fclose(stdin);
    fclose(stdout);
    return 0;
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章