hdu5747 貪心

Aaronson
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 498 Accepted Submission(s): 299

Problem Description

Recently, Peter saw the equation x0+2x1+4x2+…+2mxm=n. He wants to find a solution (x0,x1,x2,…,xm) in such a manner that ∑i=0mxi is minimum and every xi (0≤i≤m) is non-negative.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:

The first contains two integers n and m (0≤n,m≤109).

Output

For each test case, output the minimum value of ∑i=0mxi.

Sample Input

10
1 2
3 2
5 2
10 2
10 3
10 4
13 5
20 4
11 11
12 3

Sample Output

1
2
2
3
2
2
3
2
3
2
寶寶之間都沒A過BestCoder裏的題目,感覺自己還是太水了,拿個最簡單的再試試,沒想到一次就A了。可以的。

題目的意思很明顯吧,就不說了,值的一提的是, Xi是非負的整數!

這裏看n和m的範圍就知道,其實n也就是int的範圍內,所以Xi (i>30) 的取值肯定等於0。

可能有的朋友會糾結,那31和32哪去了?int 可是4個字節。

有點常識的都知道int 是補碼錶示,表示範圍是2^31 -1 到 2^31 , 所以2^31-1 >n>0。所以只考慮Xi<=30的時候。

還有一個就是題目要求SumXi 值最小,不難想到用貪心就能很好得解決了。從後向前貪。

好的, 上代碼,就幾行:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int n,m;
int main(){
    int t;
    //freopen("hdu5747.in", "rw", stdin);
    cin>>t;
    while(t--){
        scanf("%d%d", &n, &m);
        int ans=0;
        int ran=min(30, m);
        for(int i=ran;i>=0;i--){
            int tmp;
            tmp=pow(2, i);
            if(tmp>n)continue;
            ans+=n/tmp;
            n%=tmp;
        }
        printf("%d\n", ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章