A+B for Input-Output Practice (I) Java語言實驗 SDUT OJ1010

A+B for Input-Output Practice (I)

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

Your task is to Calculate a + b.

Too easy?! Of course! I specially designed the problem for acm beginners.

You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim

Input

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5
10 20

Sample Output

6
30

Hint

這是一個求兩數之和的題目,輸入多對用空格分開的兩個數a b,輸出a+b的和,每一對數據的和佔一行。編寫代碼時需要注意的是,由於沒有指出有多少對輸入數據,因此我們可以編寫如下代碼:
 //C語言
#include < stdio.h > 
int main()   //把main函數定義成int類型

      int a,b;
      while(scanf("%d %d",&a, &b) != EOF)   // 輸入結束時,scanf函數返回值爲EOF,即沒有數據輸入時則退出while循環
            printf("%d\n",a+b);
      return 0; //返回值爲0
}  

 //或者C++語言
#include < iostream >     //注意頭文件的使用方法
using namespace std;
int main()
{
       int a,b;
       while(cin >> a >> b)
            cout << a+b << endl;
       return 0;
}

Source

HDOJ

import java.util.Scanner;

public class Main 
{
	public static void main(String[] args) 
	{
	    Scanner reader = new Scanner(System.in);
	    int a, b, c;
	    while(reader.hasNext())
	    {
    	    a = reader.nextInt();
    	    b = reader.nextInt();
    	    c = a + b;
    		System.out.println(c);
	    }
		reader.close();
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章