HOJ 1797 Red and Black (DFS)

鏈接:點擊打開鏈接


There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input 

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output 

45
59
6
13


最近很受傷,連一個kiss都搞得頭昏眼花,刷個水題都腎痛~~我要療傷了~~~

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <stack>
#include <queue>
#define MAXN 30
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

char Map[MAXN][MAXN];
int vis[MAXN][MAXN], n, m, res;
int bx, by, xx, yy;
const int dx[] = {-1, 0, 1, 0};
const int dy[] = {0, 1, 0, -1};

void Init()
{
    RST(vis);
    for(int i=0; i<n; i++) {
        scanf("%s", Map[i]);
        for(int j=0; Map[i][j]; j++) {
            if(Map[i][j] == '#') vis[i][j] = 1;
            if(Map[i][j] == '@') bx=i, by=j;
        }
    }
    res = 0;
}

bool check(int x, int y)
{
    return x>=0 && x<n && y>=0 && y<m && !vis[x][y];
}

void solve(int x, int y)
{
    vis[x][y] = 1;
    for(int i=0; i<4; i++) {
        xx = x+dx[i], yy = y+dy[i];
        if(check(xx, yy)) solve(xx, yy);
    }
    res++;
}

int main()
{
    while(~scanf("%d %d", &m, &n) && n || m) {
        Init();
        solve(bx, by);
        printf("%d\n", res);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章