HDU 1520 Anniversary party————樹形dp 模板題

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

Sample Output

5

思路:

經典簡單樹形dp模板題。

ac代碼:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>

#define MAXN 6005

using namespace std;

int dp[MAXN][2], father[MAXN], n, root;

void dfs(int node) {
	for (int i = 1; i <= n; i++) {
		if (father[i] == node) {
			dfs(i);
			dp[node][1] += dp[i][0];
			dp[node][0] += max(dp[i][0], dp[i][1]);
		}
	}
}

int main()
{
	int i, j;
	while (scanf("%d", &n) != EOF) {
		if (n == 0) {
			break;
		}
		memset(dp, 0, sizeof(dp));
		memset(father, 0, sizeof(father));
		for (i = 1; i <= n; i++) {
			scanf("%d", &dp[i][1]);
		}
		int a, b;
		while (scanf("%d%d", &a, &b)) {
			if (a == 0 && b == 0) {
				break;
			}
			father[a] = b;
		}
		for (i = 1; i <= n; i++) {
			if (father[i] == 0) {
				root = i;
				break;
			}
		}
		dfs(root);
		printf("%d\n", max(dp[root][1], dp[root][0]));
	}


	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章