Stars--HDU1541(二維偏序-樹狀數組)

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

題目鏈接http://acm.hdu.edu.cn/showproblem.php?pid=1541

Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

 

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

 

 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

 

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0


題目大意:定義星星的級別是在它左邊或下邊的星星的數量,求0到N-1級別的星星的數量,給出n個星星,n行,x,y

我們可以直接先將x軸固定,然後對接下來的y在1到n-1中找比他矮的就行了。。。那麼線段樹或者樹狀數組就可以很棒地解決這個問題了

有兩個坑點注意,y可能爲0,那麼樹狀數組的lowbit(0)=0,add函數就會T掉,所以我們對每個y加上1,第二個就是要多組,沒有多組會WA。。。。

以下是AC代碼:

#include <bits/stdc++.h>
using namespace std;

const int mac=1.5e4+10;
const int maxn=3.2e4+10;

int lowbit(int x)
{
    return x&-x;
}

struct node
{
    int x,y;
}a[mac];

int n,c[32050],level[mac];

int query(int pos)
{
    int ans=0;
    while (pos>0){
        ans+=c[pos];
        pos-=lowbit(pos);
    }
    return ans;
}

void add(int pos)
{
    while (pos<=maxn){
        c[pos]+=1;
        pos+=lowbit(pos);
    }
}

bool cmp(node a,node b)
{
    if (a.x==b.x) return a.y<b.y;
    return a.x<b.x;
}

int main()
{
    while (scanf ("%d",&n)!=EOF){
        for (int i=1; i<=n; i++){
            int x,y;
            scanf ("%d%d",&x,&y);
            a[i].x=x,a[i].y=y;
        }
        sort(a+1,a+1+n,cmp);
        memset(level,0,sizeof level);
        memset(c,0,sizeof c);
        for (int i=1; i<=n; i++){
            int nb=query(a[i].y+1);
            level[nb]++;
            add(a[i].y+1);
        }
        for (int i=0; i<n; i++){
            printf ("%d\n",level[i]);
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章