HDU1212 Big Number(大數模除)

Problem Description
As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

Output
For each test case, you have to ouput the result of A mod B.

Sample Input
2 3
12 7
152455856554521 3250

Sample Output
2
5
1521
思路:通過循環不斷取模,避免超過整形範圍。
大數模除模板,在這裏需要了解兩個公式(a + b) % m = (a % m + b % m) % m和a * b %m = (a % m * b % m) % m:
AC代碼如下

#include<stdio.h>
#include<string.h>
char str[2000];
int main()
{
	int i,len,n,sum;
	while(~scanf("%s%d",str,&n))
	{
		len=strlen(str);
		sum=0;
		for(i=0;i<len;i++)//模板記住就好
			sum=(sum*10+(str[i]-'0')%n)%n;
		printf("%d\n",sum);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章