【hdu1242】Rescue——bfs+小根堆

題目:

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24209    Accepted Submission(s): 8538


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
13
 

Author
CHEN, Xue
 

Source

描述:給定多個起點和一個終點的map,求起點到終點的最短路徑,其中上下左右分別消耗一單位時間,#表示不能走,x要額外多花費一單位時間

題解:將終點當作起點,起點作爲終點進行bfs。要注意的是由於x的存在使隊列中的不是按照到起點的步長進行排序,導致得到的結果不一定是最短的,所以用優先隊列來維護這一性質。這裏學習了優先隊列表示小根堆的另一種寫法。

代碼:

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int maxn = 205;
char map[maxn][maxn];
int dx[] = { 0,0,-1,1 };
int dy[] = { -1,1,0,0 };
struct point
{
	int x;
	int y;
	int dis;
	friend bool operator< (point a,point b)
	{
		return a.dis > b.dis;
	}
};
int main()
{
	int n, m;
	point p;
	while (scanf("%d%d", &n, &m) != EOF)
	{
		getchar();
		for (int i = 0; i < n; i++)
		{
			for (int j = 0; j < m; j++)
			{
				scanf("%c", &map[i][j]);
				if (map[i][j] == 'a')
				{
					p.x = i;
					p.y = j;
				}
			}
			getchar();
		}
		priority_queue<point> que;
		p.dis = 0;
		que.push(p);
		map[p.x][p.y] = '#';
		int ans = 0;
		while (!que.empty())
		{
			point p1 = que.top();
			que.pop();
			for (int i = 0; i < 4; i++)
			{
				point temp;
				temp.x = p1.x + dx[i];
				temp.y = p1.y + dy[i];
				if (temp.x < 0 || temp.x >= n || temp.y < 0 || temp.y >= m || map[temp.x][temp.y] == '#')
					continue;
				temp.dis = p1.dis + 1;
				if (map[temp.x][temp.y] == 'x')
					temp.dis++;
				if (map[temp.x][temp.y] == 'r')
					ans = temp.dis;
				if (ans != 0)break;
				que.push(temp);
				map[temp.x][temp.y] = '#';
			}
			if (ans != 0)break;
		}
		if (ans == 0)
			printf("Poor ANGEL has to stay in the prison all his life.\n");
		else
			printf("%d\n", ans);
	}

	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章