HDU 2594 Simpsons’ Hidden Talents kmp

一、內容

 Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2. 

Input

Input consists of twolines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

二、思路

  • 理解好next數組的含義, 利用第一個串的next數組求第二個串的next值

三、代碼

#include <cstdio>
#include <cstring>
using namespace std;
const int N = 5e4 + 5;
char a[N], b[N];
int n, m, ne[N];
void kmp() {
	ne[1] = 0;
	for (int i = 2, j = 0; i <= n; i++) {
		while (j && a[i] != a[j + 1]) j = ne[j];
		if (a[i] == a[j + 1]) j++;
		ne[i] = j;
	}
	//利用a的next數組 求出滿足b的後綴的最長前綴長度
	int j = 0; 
	for (int i = 1; i <= m; i++) {
		while (j && b[i] != a[j + 1]) j = ne[j];
		if (b[i] == a[j + 1]) j++;
	} 
	//此時j就是最長的匹配長度
	if (!j) printf("0\n");
	else { for (int i = 1; i <= j; i++) printf("%c", a[i]); printf(" %d\n", j);} 
} 
int main() {
	while (~scanf("%s%s", a + 1, b + 1)) {
		n = strlen(a + 1);
		m = strlen(b + 1);
		kmp();
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章