ZJU1016-Parencodings

有如下問題:
1.整體思路是分前一個是左括號和前一個是右括號兩種情況討論
2.num記錄括號對數,首先是棧頂元素接着拋出
3.num+1
4.再多去掉一個左括號後再壓入num+1

Description

Let S = s1 s2 … s2n be a well-formed string of parentheses. S can be encoded in two different ways:

By an integer sequence P = p1 p2 ... pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
By an integer sequence W = w1 w2 ... wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

#include <iostream>
#include <stack>

using namespace std;

stack<int> s;

int main()
{
    int t,n,i,j,m,p,num;

    cin>>t;
    while (t--){
        cin>>n;
        m = 0;
        for (i = 1; i <= n; i++){
            cin>>p;
            for (j = 1; j <= p-m; j++){
                s.push(-1);
            }

            if(s.top() == -1){
                i==1 ? cout<<"1" : cout<<" 1";
                s.pop();
                s.push(1);
            }
            else{
                num = s.top();
                s.pop();
                while(s.top() != -1){
                    num += s.top();
                    s.pop();
                }
                cout<<" "<<num + 1;
                s.pop();
                s.push(num + 1);
            }
            m = p;
        }
        cout<<endl;
        while (!s.empty()) s.pop();
    }




    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章