Number lengths FZU - 1050

N! (N factorial) can be quite irritating and difficult to compute for large values of N. So instead of calculating N!, I want to know how many digits are in it. (Remember that N! = N * (N - 1) * (N - 2) * ... * 2 * 1)

Input

Each line of the input will have a single integer N on it 0 < N < 1000000 (1 million). Input is terminated by end of file.

Output

For each value of N, print out how many digits are in N!.

Sample Input
1
3 
32000 
Sample Output
1 
1 

130271

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<cmath>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        double a=1;
        for(double i=1; i<=n; i++)
        {
             a+=log(i)/log(10);
        }
        int ans=a;
        cout<<ans<<endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章