1084 Broken Keyboard (20point(s)) - C語言 PAT 甲級

1084 Broken Keyboard (20point(s))

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

題目大意:

1029 舊鍵盤 (20point(s))

設計思路:

1029 舊鍵盤(C語言)

  • 版本二:利用字符串 2,尋找完好的鍵盤並標記,再利用字符串 1 和標記,輸出損壞的鍵盤
  • 版本一:利用字符串 1 和 字符串 2 雙重遍歷,尋找損壞的鍵盤,並直接輸出
編譯器:C (gcc)
#include <stdio.h>
#include <string.h>

int main(void)
{
        int keyboard[128] = {0};
        char str[81], ch;
        int i;
        scanf("%s%c", str, &ch);
        while ((ch = getchar()) && ch != '\n') {
                keyboard[toupper(ch)] = 1;
        }
        for (i = 0; str[i] != '\0'; i++) {
                ch = toupper(str[i]);
                if (keyboard[ch - '\0'] == 0) {
                        putchar(ch);
                        keyboard[ch - '\0'] = -1;
                }
        }
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章