HDU 1800 Flying to the Mars(字符串Hash)

Flying to the Mars

題目

Time Limit:1000MS Memory Limit:32768KB

  • Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.

  • Input

Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);

  • Output

For each case, output the minimum number of broomsticks on a single line.

  • Sample Input
    4
    10
    20
    30
    04
    5
    2
    3
    4
    3
    4

  • Sample Output
    1
    2

分析

本題的解法可謂五花八門,貪心,hash,STL map,字典樹,二分查找樹,由於最近剛學了hash,就想用字符串hash來練練手。到網上搜索了下發現很多種字符串hash函數,這裏選擇了一種較優的BKDRHash,我直接抄了份模板,代碼如下:

inline unsigned int BKDRHash(char *str)
{
    unsigned int seed = 131;
    unsigned int hash = 0;
    while(*str == '0')
        str++;
    while (*str)
        hash = hash * seed + (*str++);
    return (hash & 0x7FFFFFFF);
}

hash的本質是空間換時間,在使用hash的時候尤其要注意數組大小,否則極易RE或MLE,另外有時也要小心注意時間,防止TLE。
言歸正傳,翻譯過來,本題的實質就是找出相同的level最多有多少個,實現代碼如下:

代碼

#include <cmath>
#include <cstdio>
#include <cstring>
#include <vector>
#include <iostream>
#include <algorithm>
#define M 7003
using namespace std;
char hashstr[32];
int hashtable[M];
int cnt[M];
inline unsigned int BKDRHash(char *str)
{
    unsigned int seed = 131;
    unsigned int hash = 0;
    while(*str == '0')
        str++;
    while (*str)
        hash = hash * seed + (*str++);
    return (hash & 0x7FFFFFFF);
}
int main()
{
    int n, res, t, index;
    while(scanf("%d", &n) != EOF)
    {
        res = 1;
        memset(hashtable, 0, sizeof(hashtable));
        memset(cnt, 0, sizeof(cnt));
        for(int i=0; i<n; i++)
        {
            scanf("%s", hashstr);
            index = BKDRHash(hashstr);
            t = index % M;
            while(hashtable[t]!=index && cnt[t])
                t = (t+10) % M;
            if(!cnt[t])
            {
                hashtable[t] = index;
                cnt[t]++;
            }
            else if(++cnt[t] > res)
                res = cnt[t];
        }
        printf("%d\n", res);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章