POJ 3086 Triangular Sums

Triangular Sums
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6371   Accepted: 4529

Description

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.

Output

For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.

Sample Input

4
3
4
5
10

Sample Output

1 3 45
2 4 105
3 5 210
4 10 2145

Source

找規律的一道題,其實題目已經說的很明白了。
先打表再輸出,開始怕時限,所以一直改不對,乾脆分開算。
代碼:
#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;
int f[305],T[305],sum[305];
int main()
{
    int i,j,n,m;
    T[1]=1;f[1]=1;
    for(i=2;i<305;i++)
    T[i]=i+T[i-1];
    for(i=1;i<304;i++)
    f[i]=i*T[i+1];
    sum[1]=f[1];
    for(i=2;i<305;i++)
    sum[i]=sum[i-1]+f[i];
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&m);
            printf("%d %d %d\n",i,m,sum[m]);
        }
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章