Hduoj1048【水題】

/*The Hardest Problem Ever
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19721    Accepted Submission(s): 9257


Problem Description
Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 

Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

 

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 

A single data set has 3 components: 

Start line - A single line, "START" 

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 

End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT".

 

Output
For each data set, there will be exactly one line of output. This is the original message by Caesar.

 

Sample Input
START
NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
END
START
N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
END
START
IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
END
ENDOFINPUT
 

Sample Output
IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE
 

Source
South Central USA 2002 
 

Recommend
We have carefully selected several similar problems for you:  1062 1056 1060 1113 1052 
*/
#include<stdio.h>
#include<string.h>
char s[220];
int main()
{
	int i, j, k, l;
	while(gets(s) != NULL)
	{
		if(strcmp(s,"ENDOFINPUT") == 0)
		break;
		if(strcmp(s, "START") == 0)
		{
			while(gets(s) != NULL)
			{
				if(strcmp(s, "END") == 0)
				break;
				l = strlen(s) ;
				for(i = 0; i < l; ++i)
				{
					if(s[i] >= 65 && s[i] <= 90)
					{
						s[i] -= 5;
						if(s[i] < 65)
						s[i] += 26;
					}
				}
				puts(s);
			}
		}
	}
	return 0;
}
題意:給出一段需要解碼的字符串,解碼規則是將每個大寫字母都往前移動5個,如果超出字母的界限則加上26循環着取最後面的字母。
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章