HDU 1757 A Simple Math Problem (矩陣快速冪)

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5686    Accepted Submission(s): 3481


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
45 104
 

Author
linle

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <stack>
#include <math.h>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;

typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 11;
const int n = 10;
ll mod, k;

struct Matrix
{
	ll m[maxn][maxn];
};

Matrix multi(Matrix a, Matrix b)
{
	Matrix c;
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < n; j++) {
			c.m[i][j] = 0;
			for (int k = 0; k < n; k++) {
				c.m[i][j] += a.m[i][k] * b.m[k][j]%mod;
			}
			c.m[i][j] %= mod;
		}
	}
	return c;
}

Matrix pow(Matrix a, ll nn)
{
	Matrix ans;
	memset(ans.m, 0, sizeof(ans.m));
	for(int i = 0; i < n; i++) {
		ans.m[i][i] = 1;
	}
	Matrix p = a;
	while (nn) {
		if (nn & 1) 
			ans = multi(ans, p);
		p = multi(p, p);
		nn /= 2;
	}
	return ans;
}

int main(void)
{
#ifdef ACM
		freopen("in.txt", "r", stdin);
		//freopen("out.txt", "w", stdout);
#endif

	Matrix a, ans, temp;
	while(scanf("%lld%lld", &k, &mod) != EOF) {
	memset(a.m, 0, sizeof(a.m));
	memset(temp.m, 0, sizeof(temp.m));
	for(int i = 0; i < 10; i++) {
		scanf("%lld", &a.m[0][i]);
	}
	for(int i = 1; i < 10; i++) {
		a.m[i][i-1] = 1;
	}
	for(int i = 0;i < 10; i++) {
		temp.m[i][0] = 9 - i;
	}


	if(k < 10) {
		printf("%lld\n", k % mod);
	}
	else{
		ans = pow(a, k - 9);
		ans = multi(ans, temp);
		printf("%lld\n", ans.m[0][0]);
	}
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章