POJ 3660 Cow Contest (簡單floyd)

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

大意:給出m行不同牛之間的勝負情況,求確定的排名關係

思路:一頭牛的勝數加上他的負數等於n-1的話,那他的排名就確定的,利用floyd確定各牛之間的勝負情況

上代碼

#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<stack>
#include<queue>
#include<vector>
#include<cstdio>
#include<string>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
int n;
vector<pair<int, int> >G[300];
bool M[110][110];
void floyd()
{
	for (int k = 1; k <= n; k++)
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++)
				if (M[i][j] || (M[i][k] && M[k][j]))
					M[i][j] = true;
}
int main()
{
	//freopen("Text.txt","r",stdin);
	memset(M, false, sizeof(M));
	int m, u, v;
	cin >> n >> m;
	for (int i = 1; i <= m; i++)
	{
		cin >> u >> v;
		M[u][v] = true;
	}
	floyd();
	int cnt = 0;
	for (int i = 1; i <= n; i++)
	{
		int sum = 0;
		for (int j = 1; j <= n; j++)
		{
			if (i == j)
				continue;
			if (M[i][j])
				sum++;
			if (M[j][i])
				sum++;
		}
		if (sum == n - 1)
			cnt++;
	}
	cout << cnt << endl;
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章