HDU-1548 A strange lift

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32627    Accepted Submission(s): 11699

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5

3 3 1 2 5 0

Sample Output

3

    將電梯的每一層看做一個點,則可以在該層可以到達的層數之間連接一條邊,注意,這是有向圖,然後利用最短路迪傑斯特拉算法求起點到重點的最短路就行了

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

const int INF = 0x3f3f3f3f;

int n,s,e,cnt;
bool vis[210];
bool f[210][210];
int path[210];

int Dij( int s , int e ){
    if( s==e )
        return 0;
    memset( path,INF,sizeof(path) );
    for( int i=1 ; i<=n ; i++ ){
        vis[i] = false;
        if( f[s][i] )
            path[i] = 1;
    }
    vis[s] = true;
    for( int i=1 ; i<n ; i++ ){
        int min = INF;
        int pos;
        for( int j=1 ; j<=n ; j++ ){
            if( !vis[j] && min>path[j] )
                min = path[ pos=j ];
        }
        vis[pos] = true;
        for( int j=1 ; j<=n ; j++ ){
            if( !vis[j] && f[pos][j] && path[j]>path[pos]+1 )
                path[j] = path[pos] + 1;
        }
    }
    return path[e]==INF ? -1 : path[e];
}


int main(){
    while( cin >> n && n ){
        memset( f,false,sizeof(f) );
        cin >> s >> e;
        int v;
        for( int i=1 ; i<=n ; i++ ){
            cin >> v;
            if( i-v>=1 )
                f[i][i-v] = true;
            if( i+v<=n )
                f[i][i+v] = true;
        }
        cout << Dij( s,e ) << endl;
    }
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章