Hdu 4565 So Easy! (矩陣快速冪)

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5642    Accepted Submission(s): 1875


Problem Description
  A sequence Sn is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate Sn.
  You, a top coder, say: So easy! 
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 215, (a-1)2< b < a2, 0 < b, n < 231.The input will finish with the end of file.
 

Output
  For each the case, output an integer Sn.
 

Sample Input

2 3 1 20132 3 2 20132 2 1 2013
 

Sample Output

4144


總結:公式有點難推。題意給的條件(a-1)2< b <  a2,  很重要

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <stack>
#include <math.h>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;

typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1e5 + 10;
ll _mod;

struct Matrix
{
	ll m[2][2];
};
Matrix I = {
	1,0,
	0,1
};
Matrix multi(Matrix a, Matrix b)
{
	Matrix c;
	for (int i = 0; i < 2; i++) {
		for (int j = 0; j < 2; j++) {
			c.m[i][j] = 0;
			for (int k = 0; k < 2; k++) {
				c.m[i][j] += a.m[i][k] * b.m[k][j] % _mod;
			}
			c.m[i][j] %= _mod;
		}
	}
	return c;
}

Matrix pow(Matrix a, ll n)
{
	Matrix ans = I;
	Matrix p = a;
	while (n) {
		if (n & 1) 
			ans = multi(ans, p);
		p = multi(p, p);
		n /= 2;
	}
	return ans;
}

int main()
{
#ifdef ACM
	#else
		//freopen("in.txt", "r", stdin);
		//freopen("out.txt", "w", stdout);
#endif
	ll a, b, n;
	while (scanf("%lld%lld%lld%lld", &a, &b, &n, &_mod) != EOF) {
		Matrix M, ans, temp, num;
		M.m[0][0] = 2 * a % _mod;
		M.m[0][1] = ((b % _mod - a * a % _mod) + _mod) % _mod;
		M.m[1][0] = 1;
		M.m[1][1] = 0;
		temp.m[0][0] = 2 * (a*a%_mod + b % _mod) % _mod;
		temp.m[1][0] = 2 * a % _mod;
		temp.m[1][1] = 0;
		temp.m[0][1] = 0;
		if (n == 1)
			printf("%lld\n", temp.m[1][0]);
		else {
			ans = pow(M, n - 2);
			ans = multi(ans, temp);
			printf("%lld\n", (ans.m[0][0] + _mod) % _mod);
		}

	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章