HDU - 1024 Max Sum Plus Plus(dp求最大m子段和)

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34600    Accepted Submission(s): 12359


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
1 3 1 2 32 6 -1 4 -2 3 -2 3
 

Sample Output
68
Hint
Huge input, scanf and dynamic programming is recommended.
 

Author
JGShining(極光炫影)
 

Recommend
We have carefully selected several similar problems for you:  1074 1025 1081 1080 1160 

    題意:將一段序列分成m段,求最大m段和

    狀態轉移:dp[j] = max(dp[ j-1 ]+a[ j ], Max[ j-1 ]+a[ j ]); 其中 dp[ j-1 ]+a[ j ] 代表把第 j 個數加到前一組裏,Max[ j-1 ]+a[ j ]代表將第 j 個數單分一組。

#include <bits/stdc++.h>
using namespace std;

const int N = 1e6+10, inf = 0x3f3f3f3f;
int n, m;
int a[N], dp[N], Max[N];

int main(){
    while(scanf("%d%d", &m, &n) == 2){
        for(int i = 0; i < n; i++){
            scanf("%d", &a[i]);
        }
        memset(dp, 0, sizeof dp);
        memset(Max, 0, sizeof Max);
        int maxi;
        for(int i = 1; i <= m; i++){    //分成i組
            maxi = -inf;
            for(int j = i; j < n; j++){
                dp[j] = max(dp[j-1]+a[j], Max[j-1]+a[j]);
                Max[j-1] = maxi;
                maxi = max(dp[j], maxi);
                printf("%d ", dp[j]);
            }
        }
        printf("%d\n", maxi);
    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章