2018暑假多校賽【第四場】【字符串】-Problem K. Expression in Memories-YZHHHHHHH

Problem K. Expression in Memories

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 887    Accepted Submission(s): 339
Special Judge

Problem Description

Kazari remembered that she had an expression s0 before.
Definition of expression is given below in Backus–Naur form.
<expression> ::= <number> | <expression> <operator> <number>
<operator> ::= "+" | "*"
<number> ::= "0" | <non-zero-digit> <digits>
<digits> ::= "" | <digits> <digit>
<digit> ::= "0" | <non-zero-digit>
<non-zero-digit> ::= "1" | "2" | "3" | "4" | "5" | "6" | "7" | "8" | "9"
For example, `1*1+1`, `0+8+17` are valid expressions, while +1+1, +1*+1, 01+001 are not.
Though s0 has been lost in the past few years, it is still in her memories. 
She remembers several corresponding characters while others are represented as question marks.
Could you help Kazari to find a possible valid expression s0 according to her memories, represented as s, by replacing each question mark in s with a character in 0123456789+* ?

Input

The first line of the input contains an integer T denoting the number of test cases.
Each test case consists of one line with a string s (1≤|s|≤500,∑|s|≤105).
It is guaranteed that each character of s will be in 0123456789+*? .

Output

For each test case, print a string s0 representing a possible valid expression.
If there are multiple answers, print any of them.
If it is impossible to find such an expression, print IMPOSSIBLE.

Sample Input

5

?????

0+0+0

?+*??

?0+?0

?0+0?

Sample Output

11111

0+0+0

IMPOSSIBLE

10+10

IMPOSSIBLE


題意:

有一個表達式,由數字、操作符和問號表示,問號可以用  1~9  和 兩個操作符來替代,

如果   表達式合法: 1、無前導零  2、操作符不相鄰  3、第一位和最後一位不爲操作符

    輸出該表達式

否則

    輸出   IMPOSSIBLE

注意幾種情況,除了樣例外給幾組數據測試: 

1、0?

2、0?0??

3、100?+1

代碼:

(代碼略長)

#include <stdio.h>
#include <string.h>
using namespace std;
int main(){
	int t;
	while (scanf("%d",&t) != EOF){
		getchar();
		while (t--) {
			char s[1005];
			gets(s);
			int len = strlen(s);
			int sigh = 0;
			s[len] = '+';
			for (int i = 0; i < len; i++){
				if (s[i] == '?'){
					if (i == 0) s[i] = '1';
					else if (i == 1) {
						if (s[i-1] == '0') s[i] = '+';
						else s[i] = '1';
					}
					else {
						if((s[i-1]=='0'&&(s[i-2] >= '0' && s[i-2] <= '9'))||s[i-1]!='0') s[i]='1';
                    	else    s[i]='+';
					}
				}
			}
			for (int i = 0; i < len; i++){
				if(i==0){
	                if(s[i]=='0')   if(s[i+1] >= '0' && s[i+1] <= '9') {
	                sigh = 1;
					}
	                if(s[i]=='+'||s[i]=='*')    sigh=1;
	            }
	            else{
	                if((s[i]=='+'||s[i]=='*')&&(s[i+1]=='+'||s[i+1]=='*'))    sigh=1;
	                if(s[i]=='0'&&(s[i-1]=='+'||s[i-1]=='*')&& (s[i+1] >= '0' && s[i+1] <= '9')){
	                	
	                	sigh = 1;
					}
	            }
			}
			//puts(s);
			if (sigh) printf("IMPOSSIBLE\n");
			else {
				for (int i = 0; i < len; i++){
					printf("%c",s[i]);
				}
				printf("\n");
			}
		}
	}
}

 

 

 

 

 

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章