Sicily 1099 Packing Passengers

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

PTA, Pack ‘em Tight Airlines is attempting the seemingly impossible—to fly with only full planes and still make a profit. Their strategy is simplicity and efficiency. Their fleet consists of 2 types of equipment (airline lingo for airplanes). Type A aircraft cost costA dollars to operate per flight and can carry passengersA passengers. Type B aircraft cost costB dollars to operate per flight and can carry passengersB passengers.

PTA has been using software that works well for fewer than 100 passengers, but will be far too slow for the number of passengers they expect to have with larger aircraft. PTA wants you to write a program that fills each aircraft to capacity (in keeping with the name Pack 'em Tight) and also minimizes the total cost of operations for that route.

Input

The input file may contain data sets. Each data set begins with a line containing the integer n (1 <= n <= 2,000,000,000) which represents the number of passengers for that route. The second line contains costA and passengersA, and the third line contains costB and passengersB. There will be white space between the pairs of values on each line. Here, costA, passengersA, costB, and passengersB are all nonnegative integers having values less than 2,000,000,001.
After the end of the final data set, there is a line containing “0” (one zero) which should not be processed.

Output

For each data set in the input file, the output file should contain a single line formatted as follows:
Data set <N>: <A> aircraft A, <B> aircraft B
Where <N> is an integer number equal to 1 for the first data set, and incremented by one for each subsequent data set, <A> is the number of airplanes of type A in the optimal solution for the test case, and <B> is the number of airplanes of type B in the optimal solution. The 'optimal' solution is a solution that lets PTA carry the number of passengers specified in the input for that data set using only airplanes loaded to their full capacity and that minimizes the cost of operating the required flights. If multiple alternatives exist fitting this description, select the one that uses most airplanes of type A. If no solution exists for PTA to fly the given number of passengers, the out line should be formatted as follows:
Data set <N>: cannot be flown

Sample Input

600
30 20
20 40
550
1 13
2 29
549
1 13
2 29
2000000000
1 2
3 7
599
11 20
22 40
0

Sample Output

Data set 1: 0 aircraft A, 15 aircraft B
Data set 2: 20 aircraft A, 10 aircraft B
Data set 3: 11 aircraft A, 14 aircraft B
Data set 4: 6 aircraft A, 285714284 aircraft B
Data set 5: cannot be flown

Solution

給出總的人數total,給出costA和passA,costB和passB,求出一組解(x,y)使得在滿足x*passA + y*passB的時候min{x*costA + y*costB}。這是一個簡單的數學題,注意邊界條件就可以了。

用y表示x,然後代入min{x*costA + y*costB}中得到一個一元方程,分類討論y的最優解即可。注意極端數據0 0 0 0即可,中間計算結果用long long。

#include <cstdio>
#include <algorithm>

using namespace std;

typedef long long ll;

int main()
{
	ll tot, count = 0;

	while (scanf("%lld", &tot) != EOF && tot)
	{
		ll a, b, c, d, x, y;
		bool has = true;
		bool flag = false;

		scanf("%lld%lld%lld%lld", &a, &c, &b, &d);
		if (c == 0 || d == 0)
		{
			if (d == 0 && c == 0) has = false;
			else if (d == 0 && c != 0)
			{
				if (tot % c) has = false;
				else x = tot / c;
			}
			else if (c == 0 && d != 0)
			{
				if (tot % d) has = false;
				else y = tot / d;
			}
		}
		else
		{
			if (a*d <= b*c)
			{
				swap(a, b);
				swap(c, d);
				flag = true;
			}
			if (a*d == b*c) y = tot / d;
			else y = min(tot / d, a*tot/(a*d-c*b));
			x = (tot - y*d) / c;
			while (x*c + y*d != tot && y > 0)
			{
				--y;
				x = (tot - y*d) / c;
			}
			if (y == 0 && x*c + y*d != tot) has = false;
		}

		count ++;
		printf("Data set %lld: ", count);
		if (!has) printf("cannot be flown\n");
		else
		{
			if (flag) printf("%lld aircraft A, %lld aircraft B\n", y, x);
			else printf("%lld aircraft A, %lld aircraft B\n", x, y);
		}
	}

	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章