ACM Packets(挑戰程序設計競賽)

Packets

Time Limit: 1000ms
Memory Limit: 10000KB
This problem will be judged on PKU. Original ID: 1017
64-bit integer IO format: %lld      Java class name: Main
A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source

#include <iostream>
#include <cstdio>

using namespace std;

int num[7];

int main()
{
    for(int i=1;i<=6;i++)
        scanf("%d",&num[i]);

    while(1)
    {
        bool over=true;;

        for(int i=1;i<=6;i++)
            if(num[i]) over=false;
        if(over) break;

        int cnt=0;
        for(int i=6;i>=1;i--)
        {
            int rest=0,rest2,n3,n2;
            switch(i)
            {
            case 6:
                if(!num[i]) break;
                cnt+=num[i];
                break;
            case 5:
                if(!num[i]) break;
                cnt+=num[i];
                if(num[1]>num[i]*11)
                    num[1]-=num[i]*11;
                else
                    num[1]=0;
                break;
            case 4:
                if(!num[i]) break;
                cnt+=num[i];
                if(num[2]>num[i]*5)
                {
                    num[2]-=num[i]*5;
                    rest=0;
                }
                else
                {
                    rest=(num[i]*5-num[2])*4;
                    num[2]=0;
                }
                if(rest)
                {
                    if(num[1]>=rest)
                        num[1]-=rest;
                    else
                        num[1]=0;
                }
                break;
            case 3:
                if(!num[i]) break;
                n3=num[i]/4;
                if(num[i]%4)
                {
                    n3++;
                    rest=(4-(num[i]%4));
                }
                cnt+=n3;
                if(rest)
                {
                    if(rest==1) rest2=1;
                    else if(rest==2) rest2=3;
                    else if(rest==3) rest2=5;
                    int tr=0;

                    if(num[2]>=rest2)
                    {
                        tr=rest*9-rest2*4;
                        num[2]-=rest2;
                    }
                    else
                    {
                        tr=rest*9-(rest2-num[2])*4;
                        num[2]=0;
                    }
                    if(num[1]>=tr)
                        num[1]-=tr;
                    else
                        num[1]=0;
                }
                break;
            case 2:
                if(!num[i]) break;
                n2=num[i]/9;
                if(num[i]%9)
                    n2++;
                cnt+=n2;
                if(num[i]%9)
                {
                    rest=(9-num[i]%9)*4;
                    if(num[1]>=rest)
                        num[1]-=rest;
                    else
                        num[1]=0;
                }
                break;
            case 1:
                if(!num[i]) break;
                cnt+=num[1]/36;
                if(num[1]%36)
                    cnt++;
                break;
            }
        }

        printf("%d\n",cnt);

        for(int i=1;i<=6;i++) scanf("%d",&num[i]);
    }

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章