HDOJ 1001 Sum Problem

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1 100

Sample Output

1

 

5050

Author

DOOM III

Recommend

We have carefully selected several similar problems for you:  1002 1090 1003 1091 1004

 

code:

#include<cstdio>

int main(){
  int num,sum;
  while(scanf("%d", &num) != EOF){
    sum = (num % 2 == 0)?((1 + num) * (num / 2)) : ((1 + num) * (num / 2) + num / 2 + 1);
    printf("%d\n\n", sum);
    }
  return 0;
}

tips:

1、區分奇數偶數

2、output裏在每行答案間多了一個回車

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章