HDU 1814 Peaceful Commission 2-sat 輸字典序最小的可行解

                                            HDU 1814  Peaceful Commission

The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others.

The Commission has to fulfill the following conditions:
1.Each party has exactly one representative in the Commission,
2.If two deputies do not like each other, they cannot both belong to the Commission.

Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party .

Task
Write a program, which:
1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms,
2.decides whether it is possible to establish the Commission, and if so, proposes the list of members,
3.writes the result in the text file SPO.OUT.

Input

In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other.
There are multiple test cases. Process to end of file.

Output

The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence.

Sample Input

3 2
1 3
2 4

Sample Output

1
4
5

 

題目大意:

有n個政黨,每個政黨有2個代表,現在需要組合一個會議,有些代表之間有矛盾,不能共同參會,問是否有可行方案,有則輸出字典序最小的方案。

 

題解:

從1-2*N 依次枚舉是否能作爲方案中的參會人員,如果有矛盾則不行,如果每個政黨的第一個不行,則利用模擬棧撤回標記,然後再嘗試第二個代表,若兩個都不行,則說明無可行參賽方案。

 

#include <bits/stdc++.h>

using namespace std;
const int maxn = 8000 * 2 + 100;
vector <int> G[maxn];
bool used[maxn];
int n,m,top;
int sta[maxn];

bool dfs(int x)
{
	if(used[x^1]) return false;
	if(used[x])   return true;
	used[x] = true;
	sta[top++] = x;
	for(int i = 0; i < G[x].size(); i++)
	  if(!dfs(G[x][i])) return false;
	return true;
}

bool judge()
{
	memset(used,false,sizeof(used));
	for(int i = 0; i < 2*n; i++)
	{
		if(!used[i] && !used[i^1])
		{
			top = 0;
			if(!dfs(i))
			{
				for(int j = 0; j < top; j++)
				   used[sta[j]] = false;
				top = 0;
				if(!dfs(i^1)) return false;
			}
		}
	}
	return true;
}

int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		for(int i = 0; i < 2*n; i++) G[i].clear();
		for(int i = 0; i < m; i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			u--,v--;
			G[u].push_back(v^1);
			G[v].push_back(u^1);
		}
		if(judge())
			{
				for(int i = 0; i < 2*n; i++)
			  if(used[i]) printf("%d\n",i+1);
			}
		else puts("NIE");
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章