RIP,EIGRP,OSPF路由重分發實驗(9)

RIP,EIGRP,OSPF路由重分發實驗(9)

重拾CCNA,筆記持續更新ing...

今天天氣不錯...

廢話不說,直接上圖:

 

 

說說具體做法:R1直接起RIP協議,R3起EIGRP,R4起OSPF,R2相對應端口做相應的協議:

直接把show RUn 貼來

R1:Router#show run
Building configuration...

Current configuration : 696 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 ip address 192.168.1.1 255.255.255.0
!
interface Serial1/3
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.1.0
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

R2:

Router(config)#do show run
Building configuration...

Current configuration : 1147 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 ip address 192.168.2.2 255.255.255.0
 clock rate 64000
!
interface Serial1/2
 ip address 192.168.1.2 255.255.255.0
 clock rate 64000
!
interface Serial1/3
 ip address 192.168.3.2 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 100
 redistribute rip metric 1000 1 255 1 1500
 redistribute ospf 1 metric 2 1000 255 1 1500
 network 192.168.3.0
 auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute rip metric 1000 subnets
 redistribute eigrp 100 metric 1000 subnets
 network 192.168.2.0 0.0.0.255 area 0
!
router rip
 version 2
 redistribute eigrp 100 metric 10
 redistribute ospf 1 metric 2
 network 192.168.1.0
 no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

R3:

R3#show run
Building configuration...

Current configuration : 870 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname eigrp-r3
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 ip address 192.168.3.1 255.255.255.0
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 100
 network 192.168.3.0
 network 3.3.3.0 0.0.0.255
 no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 login
!
!
!
end

R4:


Router#show run
Building configuration...

Current configuration : 787 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 ip address 192.168.2.1 255.255.255.0
!
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 192.168.2.0 0.0.0.255 area 0
!
ip classless
!

做完之後全網互通,現在把路由表貼出來,大神們看看對不對:

R1:Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     3.0.0.0/24 is subnetted, 1 subnets
R       3.3.3.0 [120/10] via 192.168.1.2, 00:36:44, Serial1/2
C    192.168.1.0/24 is directly connected, Serial1/2
R    192.168.2.0/24 [120/2] via 192.168.1.2, 00:37:08, Serial1/2
R    192.168.3.0/24 [120/10] via 192.168.1.2, 00:36:44, Serial1/2

R2:

Router(config)#do show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/20640000] via 192.168.3.1, 00:40:03, Serial1/3
C    192.168.1.0/24 is directly connected, Serial1/2
C    192.168.2.0/24 is directly connected, Serial1/1
C    192.168.3.0/24 is directly connected, Serial1/3

R3:

R3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
D EX 192.168.1.0/24 [170/20514560] via 192.168.3.2, 00:34:26, Serial1/3
D EX 192.168.2.0/24 [170/1280768000] via 192.168.3.2, 00:33:28, Serial1/3
C    192.168.3.0/24 is directly connected, Serial1/3

R4:

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     3.0.0.0/24 is subnetted, 1 subnets
O E2    3.3.3.0 [110/1000] via 192.168.2.2, 00:02:27, Serial1/1
O E2 192.168.1.0/24 [110/1000] via 192.168.2.2, 00:04:12, Serial1/1
C    192.168.2.0/24 is directly connected, Serial1/1
O E2 192.168.3.0/24 [110/1000] via 192.168.2.2, 00:02:27, Serial1/1

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章