Oulipo -kmp模板

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<set>
#include<map>
#define inf 0x3f3f3f3f
#define ll long long
#define pi acos(-1)
using namespace std;
char mo[1000009];
int next1[1000009];
char str[1000009];
void getnext()
{
	next1[0] = -1;
	int i = 0,j = -1;
	int len = strlen(mo);
	while(i < len)
	{
		if(j == -1 || mo[i] == mo[j])//如果是第一次或要進行的和他前面的指定位置相同 
		{
			i++;
			j++;//主串和副串一起前進 
			next1[i] = j;//記錄匹配長度 
		}
		else{
			j = next1[j];//不行找他記錄的上一個可以匹配到的 
		}
	}
}//對模式串進行操作 
int kmp()
{
	int ans = 0;
	int i = 0,j = 0;
	int len1 = strlen(mo);
	int len2 = strlen(str);
	while(i < len2)
	{
		if(mo[j] == str[i] || j == -1)
		{
			i++;j++;
		}
		else{
			j = next1[j];
		}
		if(j == len1)
		{//這裏是找到匹配位置的地方,i存在主串的位置用時搞就行 
			ans++;//記錄有幾次匹配 
			j = next1[j]; //繼續執行 
		}
	}
	return ans;//返回幾次 
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%s",&mo);//存好模式串 
		scanf("%s",&str);//主串(最長的 ) 
		getnext();//搞出next數組 
		printf("%d\n",kmp());//kmp輸出主串中有幾個匹配串 
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章