鏈式前向星存圖-dinic

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases. 
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000) 
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

Sample Output

Case 1: 1
Case 2: 2
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <vector>
#include <queue>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
const int maxn = 1e2+6;
const int maxm = 2e4+10;
struct Edge{
	int from, to, cap, flow;
	Edge(){}
	Edge(int from, int to, int cap, int flow):from(from), to(to), cap(cap), flow(flow){}
};
struct dinic
{
	int n, m, s, t;//n 爲節點數 m爲邊數 s爲源點 t爲匯點 
	Edge edges[maxm];
	int head[maxn], next[maxm];
	bool vis[maxn];
	int d[maxn];
	int cur[maxn];
	
	void init(int n, int s, int t)
	{
		this->n = n;
		this->s = s;
		this->t = t;
		memset(head, -1, sizeof(head));
		m = 0;	
	} 
	
	void Add_edge(int from, int to, int cap)
	{
		edges[m] = Edge(from, to, cap, 0);
		next[m] = head[from];
		head[from] = m++;
		
		edges[m] = Edge(to, from, 0, 0);
		next[m] = head[to];
		head[to] = m++;
	}
	
	bool bfs()
	{
		memset(vis, 0, sizeof(vis));
		queue<int> Q;
		Q.push(s);
		d[s] = 0;
		vis[s] = true;
		while(!Q.empty())
		{
			int x = Q.front();
			Q.pop();
			for(int i = head[x];i != -1;i = next[i])
			{
				Edge& e = edges[i];
				if(!vis[e.to] && e.cap > e.flow)
				{
					vis[e.to] = true;
					d[e.to] = d[x] + 1;
					Q.push(e.to);
				}
			}
		}
		return vis[t];
	} 
	
	int dfs(int x, int a)
	{
		if(x == t || a == 0) return a;
		int flow = 0, f;
		for(int& i = cur[x] ;i != -1;i = next[i])
		{
			Edge& e = edges[i];
			if(d[x] + 1 == d[e.to] && (f = dfs(e.to, min(a, e.cap-e.flow) ) ) > 0 )
			{
				e.flow += f;
				edges[i^1].flow -= f;
				flow += f;
				a -= f;
				if(a == 0) break;
			}
		}
		return flow;
	}
	
	int maxflow()
	{
		int flow = 0;
		while(bfs())
		{
			for(int i = 1;i <= n;++i)
			{
				cur[i] = head[i];
			}
			flow += dfs(s, inf);
		}
		return flow;
	}
}gao;
int main()
{
	int t;
	scanf("%d", &t);
	int cnt = 1;
	while(t--)
	{
		int n, m;
		scanf("%d%d", &n, &m);
		gao.init(n, 1, n);//初始化數組
		while(m--)
		{
			int u, v, w;
			scanf("%d%d%d", &u, &v, &w);
			gao.Add_edge(u, v, w);//把每邊加入
		}
		printf("Case %d: %d\n",cnt++,gao.maxflow());//輸出最大流
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章