C - Air Raid

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles. 

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper. 

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format: 

no_of_intersections 
no_of_streets 
S1 E1 
S2 E2 
...... 
Sno_of_streets Eno_of_streets 

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections. 

There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town. 

翻譯:一個城鎮有n個路口,由一些單向馬路連接。現在要安排一些傘兵降落在某些路口上,清查所有的路口。一個傘兵可以沿着馬路一路清查過去。清查過程中不能有兩個傘兵同時清查一個路口(應該是爲了防止暴露)。給定城鎮的線路,求最少需要幾個人傘兵就能清查所有的路口

第一個整數表示測試數據的組數。 
對於每組測試數據,第一行一個整數n表示路口數量。 
第三行一個整數m表示馬路的數量 
接下來m行,每行兩個整數表示一條單向路徑。

輸出最少需要的傘兵數量

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

題解:二分圖板子題

套個板子湊一下樣例ac

#include <iostream> 
#include <cstring>
#include <cstdio>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn = 1e3+9;
int line[maxn][maxn];
int used[maxn];int n, m;
int nxt[maxn];
bool find(int x)
{
	for(int i = 1;i <= n;++i)
	{
		if(line[x][i] && !used[i])
		{
			used[i] = 1;
			if(nxt[i] == -1 || find(nxt[i]))
			{
				nxt[i] = x;
				return true;
			}
		}
	}
	return false;
}
int match()
{
	int sum = 0;
	for(int i = 1;i <= n;++i)
	{
		memset(used, 0, sizeof(used));
		if(find(i))
		{
			sum++;
		}
	}
	return sum;
}
int main()
{
	int t;
	scanf("%d", &t);
	while(t--)
	{
		memset(line, 0, sizeof(line));
		memset(nxt, -1, sizeof(nxt));
		scanf("%d", &n);
		scanf("%d", &m);
		int x, y;
		for(int i = 0;i < m;++i)
		{
			scanf("%d%d", &x, &y);
			line[x][y] = 1;
		}
		cout << n - match() << endl;
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章