HDU3032 Nim or not Nim?(Lasker’s Nim遊戲)

Nim or not Nim?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3759    Accepted Submission(s): 1937


Problem Description
Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
 

 

Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
 

 

Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
 

 

Sample Input
2 3 2 2 3 2 3 3
 

 

Sample Output
Alice Bob
 

 

Source
 

 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  3031 3033 3038 3035 3034 
 
題解:

每一輪允許兩會中操作之一:①從一堆石子中取走任意多個②將一堆數量不少於2的石子分成都不爲空的兩堆。
這個問題可以用SG函數來解決。首先,操作①其實和Nim遊戲沒什麼區別,對於一個石子數爲k的點來說,後繼可以爲0…k-1。而操作②實際上是把一個遊戲分成了兩個遊戲。根據遊戲的和的概念,這兩個遊戲的和應該爲兩個子游戲的SG函數值的異或。而求某一個點的SG函數要利用它的後繼,它的後繼就應該爲當前局面能產生的所有單一遊戲,以及當前局面所有能分成的多個單一遊戲的遊戲的和。
比如說,狀態3的後繼有:0、1、2、(1,2),他們的SG值分別爲0、1、2、3,所以sg(3) = 4。
那麼這樣,我們就能用SG函數解決這個問題。
但是,如果數據範圍非常大的時候SG函數就不能用了,通過打表可以發現一個更優美的結論:

if(x%4==0) sg[x]=x-1;
if(x%4==1||x%4==2) sg[x]=x;
if(x%4==3) sg[x] = x+1。

 
參考代碼:
#include<bits/stdc++.h>
using namespace std;
#define N 1000000
int T,n,x,ans;

int get_sg(int x)
{
    if(x%4==0) return x-1;
    else if(x%4==1||x%4==2) return x;
    else if(x%4==3) return x+1;
}
int main()
{
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d",&n);ans=0;
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&x);
            ans^=get_sg(x);
        }
        if(ans) puts("Alice");
        else puts("Bob");
    }
    return 0;
}
View Code

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章