POJ1704 Georgia and Bob(Nim博弈變形)

Georgia and Bob
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 14312   Accepted: 4840

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

 


題解:

我們把相鄰兩給位置組成一對,如果N爲奇數的話,就讓第一個數和0組成一對,然後考慮每一對,無論前面的位置移動多少,後面一個點總能移動相同的距離使得兩個點對之間的距離保持不變,所以我們就可以將每一對之間的距離拿出來,就變成了了這(N+1)/2個數之間的NIM博弈了,異或即可,很巧妙的一道題。

 

參考代碼:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=1010;
int T,n,a[maxn],ans;

int main()
{
    scanf("%d",&T);
    while(T--)////
    {
        scanf("%d",&n);
        for(int i=1;i<=n;++i) scanf("%d",&a[i]);
    
        sort(a+1,a+n+1);
        ans=0; a[0]=0;
        for(int i=n;i>0;i-=2)
            ans^=(a[i]-a[i-1]-1);    
        if(ans) puts("Georgia will win");
        else puts("Bob will win");        
    }

    return 0;
}
View Code

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章