HDU5952--Counting Cliques--DFS

Counting Cliques

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5414    Accepted Submission(s): 1929


 

Problem Description

A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph.

 

 

Input

The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.

 

 

Output

For each test case, output the number of cliques with size S in the graph.

 

 

Sample Input


 

3 4 3 2 1 2 2 3 3 4 5 9 3 1 3 1 4 1 5 2 3 2 4 2 5 3 4 3 5 4 5 6 15 4 1 2 1 3 1 4 1 5 1 6 2 3 2 4 2 5 2 6 3 4 3 5 3 6 4 5 4 6 5 6

 

 

Sample Output


 

3 7 15

 

 

Source

2016ACM/ICPC亞洲區瀋陽站-重現賽(感謝東北大學)

 

問有多少個S元團

思路,建圖的時候把無向圖變成有向圖,從小到大連邊。

若當前d元環+x的度<s,剪枝。

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int T;
int n,m,s;
vector<int> g[105];
bool graph[105][105];
int ans;
int path[105];
void dfs(int u,int d) { //當前搜索u點,已經找到d個點的完全圖
    if(d==s) {
        ans++;
        return;
    }
    //if(g[u].size()+d<s)
       // return;
    for(int i=0;i<g[u].size();i++) {
        int v=g[u][i];
        bool flag=true;
        for(int j=0;j<d;j++) {
            if(!graph[v][path[j]])
                flag=false;
            if(g[v].size()+1+d<s)
                flag=false;
            if(!flag) break;
        }
        if(flag) {
            path[d]=v;
            dfs(v,d+1);
        }
 
    }
}
int main() {
 
    scanf("%d",&T);
    while(T--) {
        scanf("%d %d %d",&n,&m,&s);
        for(int i=1;i<=n;i++)
            g[i].clear();
        memset(path,0,sizeof(path));
        memset(graph,0,sizeof(graph));
        while(m--) {
            int u,v;
            scanf("%d %d",&u,&v);
            graph[u][v]=graph[v][u]=1;
            g[min(u,v)].push_back(max(u,v));
        }
        ans=0;
        for(int i=1;i<=n;i++) {
 
                path[0]=i;
                dfs(i,1);
        }
        printf("%d\n", ans);
    }
}
 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章