UVa 340 - Master-Mind Hints

Master-Mind Hints

MasterMind is a game for two players.  One of them, Designer, selects a secret code.  The other,  Breaker, tries to break it.  A code is no more than a row of colored dots.  At the beginning of a  game, the players agree upon the length N that a code must have and upon the colors that may  occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code.   After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code tex2html_wrap_inline35  and a guess  tex2html_wrap_inline37 , and are to determine the  hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i,j),  tex2html_wrap_inline41  and  tex2html_wrap_inline43 ,  such that  tex2html_wrap_inline45 .  Match (i,j) is called strong when  i = j, and is called weakotherwise.  Two matches (i,j) and (p,q) are called independentwhen i = p if  and only if j = q.  A set of matches is called independent when all of its members are pairwise  independent.

Designer chooses an independent set M of matches for which the total number of matches and the  number of strong matches are both maximal.  The hint then consists of the number of strong  followed by the number of weak matches in M.  Note that these numbers are uniquely determined  by the secret code and the guess.  If the hint turns out to be (n,0), then the guess is identical to the  secret code.

Input

The input will consist of data for a number of games.  The input for each game begins with an  integer specifying N (the length of the code).    Following these will be the secret code,  represented as N integers, which we will limit to the range 1 to 9.  There will then follow an  arbitrary number of guesses, each also represented as Nintegers, each in the range 1 to 9.   Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a  guess.

Following the data for the first game will appear data for the second game (if any) beginning with  a new value for N.  The last game in the input will be followed by a single zero (when a value for  Nwould normally be specified).  The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order,  one hint per line.  Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma.  The entire list of hints for each game should be prefixed by a heading  indicating the game number; games are numbered sequentially starting with 1.  Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)

 

 

 

 

#include <stdio.h>
#include <string.h>
int main()
{
  int k=1,s[1005],g[1005],i,n,a[12],b[12],num1,num2;
  while((scanf("%d",&n)!=EOF)&&n!=0)
  {
      printf("Game %d:\n",k++);
      memset(a,0,sizeof(int)*12);
      memset(b,0,sizeof(int)*12);
      for(i=0;i<n;i++)
      {
        scanf("%d",&s[i]);
        a[s[i]]++;
        b[s[i]]++;
      }
      while(1)
      {
          num1=0;
          num2=0;
          for(i=1;i<=9;i++)
              b[i]=a[i];
          for(i=0;i<n;i++)
          {
              scanf("%d",&g[i]);
              if(i==n-1&&g[i]==0)break;
              else
                  if(g[i]==s[i])
                  {
                      num1++;
                      b[g[i]]--;
                  }
          }
          for(i=0;i<n;i++)
                  if(b[g[i]]>0&&g[i]!=s[i])
                   {
                      num2++;
                      b[g[i]]--;
                   }
          if(g[0]!=0)printf("    (%d,%d)\n",num1,num2);
          else break;
      }
  }
    return 0;
}


 

 

發佈了33 篇原創文章 · 獲贊 0 · 訪問量 7570
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章