UVa 10420 - List of Conquests

Problem B
List of Conquests
Input:
standard input
Output:
standard output
Time Limit:
2 seconds

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina, il catalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000lines, but the first. The first line contains a number n, indicating that there will be nmore lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3
Spain Donna Elvira
England Jane Doe
Spain Donna Anna

Sample Output

England 1

Spain 2


Problem-setter:Thomas Tang, Queens University, Canada

“Failure to produce a reasonably good and error free problem set illustrates two things a) Lack of creativity b) Lack of commitment”

 

 

 

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int cmp(const void *a, const void *b)
{
    return strcmp((char *) a,(char *) b);
}

int main()
{
    int num,i,j,n;
    char s[2005][80],c[2005][80];
    scanf("%d",&n);
    getchar();
    for(i=0;i<n;i++)
        gets(s[i]);
    qsort(s,n,sizeof(s[0]),cmp);
    for(i=0;i<n;i++)
        sscanf(s[i],"%s",c[i]);
    num=0;
    for(i=1;i<=n;i++)
        if(strcmp(c[i],c[i-1])==0)
            {
                if(strcmp(s[i],s[i-1])!=0)num++;
            }
        else
        {
            if(strcmp(s[i],s[i-1])!=0)num++;
            printf("%s %d\n",c[i-1],num);
            num=0;
        }
    return 0;
}


 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章