POJ 2955 Brackets 區間DP


Brackets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8617   Accepted: 4608

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

[Submit]   [Go Back]   [Status]   [Discuss]

link:http://poj.org/problem?id=2955


思路:區間DP,查找區間中不能配對的最大括號數 dp[1][n],輸出 len-dp[1][n];

AC code:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int INF=0x3f3f3f3f;
const int maxn=150;
char s[maxn];
int dp[maxn][maxn];

int main(){
    while(~scanf("%s",s)){
        if(strcmp(s,"end")==0) break;
        memset(dp,0,sizeof(dp));
        int len=strlen(s);
        for(int i=0;i<len;i++) dp[i][i]=1; //自身爲1
        for(int l=2;l<=len;l++){           //枚舉長度l
            for(int i=0;i+l<=len;i++){     //枚舉起點i
                int j=i+l-1;               //終點=起點+長度-1
                dp[i][j]=INF;              //查找最大
                if((s[i]=='('&&s[j]==')')||(s[i]=='['&&s[j]==']'))
                    dp[i][j]=dp[i+1][j-1]; //外圍匹配成功
                //匹配失敗則枚舉劃分界限k
                for(int k=i;k<j;k++) dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]);  
            }
        }
        printf("%d\n",len-dp[0][len-1]);
    }
}


發佈了60 篇原創文章 · 獲贊 7 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章