HDOJ 1541 Stars

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11454    Accepted Submission(s): 4560


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
1 2 1 1 0

解題思路:數狀數組可以對區間進行求和,利用這個性質,來求解答案

代碼如下:

#include <cstdio>
#include <cstring>
using namespace std;
#define N 32005
int n,c[N],ans[N],x,y;
int lowbit(int k)
{
    return k&-k;
}
int sum(int x)
{
    int ret=0;
    while(x>0)
    {
        ret+=c[x];
        x-=lowbit(x);
    }
    return ret;
}
void add(int x,int d)
{
    while(x<=N)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}
int main()
{
    int i,j,k;
    while(~scanf("%d",&n))
    {
        memset(ans,0,sizeof(ans));
        memset(c,0,sizeof(c));
        for(i = 1; i<=n; i++)
        {
            scanf("%d%d",&x,&y);
            x++; //x加一的目的是防止x出現0的情況,樹狀數組不能對0進行操作 
            ans[sum(x)]++;   //sum[] 表示的當前的和(x點前面的個數),ans[],表示在這種和的情況的個數 
            add(x,1);  //進行相加操作 
        }
        for(i = 0; i<n; i++)
            printf("%d\n",ans[i]);  
    }

    return 0;
}

發佈了189 篇原創文章 · 獲贊 77 · 訪問量 11萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章