CSU-ACM2017暑期訓練12-KMP D - 匹配

D - 匹配

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

    For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cstring>
#include <queue>
using namespace std;
const int max1 = 1e6+4, max2 = 1e4+4;

int Next[max2], s[max2], ss[max1];

int m, n;

int getNext(){
   Next[0] = Next[1] = 0;
   for(int i = 1; i < m - 1; i++){
       int j = Next[i];
       while(j && s[i] != s[j])
           j = Next[j];
       if(s[i] == s[j])
           Next[i+1] = j + 1;
       else
           Next[i+1] = 0;
   }
}

int Find(){
   int j = 0;
   for(int i = 0; i < n; i++){
       while(j && s[j] != ss[i])
           j = Next[j];
       if(s[j] == ss[i])
           j++;
       if(j == m)
           return i - m + 1 + 1;
   }
   return -1;
}

int main(){
#ifdef TEST
freopen("test.txt", "r", stdin);
#endif // TEST

   int T;
   cin >> T;
   while(T--){
       memset(Next, 0, sizeof(Next));
       cin >> n >> m;
       for(int i = 0; i < n; i++)
           scanf("%d", &ss[i]);
       for(int i = 0; i < m; i++)
           scanf("%d", &s[i]);
       getNext();
       cout << Find() << endl;
   }

   return 0;
}
發佈了68 篇原創文章 · 獲贊 7 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章