CSU-ACM2017暑假訓練9-區間DP F - Running

F - Running

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

對於這題,有兩類,共三種狀態,分別爲:第一類第一種,“疲勞值未滿,繼續奔跑”;第二類第一種,“從某時刻開始的休息結束了”;第二類第二種,“儘管之前已經休息了,但還是繼續休息”。

I.1:   II.1:   II.2:   dp[i][j]=dp[i1][j1]+sample[i]dp[i][0]=dp[ik][k]dp[i][0]=dp[i1][0]

其中,dp[i][j] 表示在第 i 分鐘,疲勞值爲 j 的情況下馬所奔跑的最長路程;sample[i] 表示在第 i 分鐘內馬所能奔跑的路程。
只需要按照上述方程遞推到 i=n 即可得到答案。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cstring>
#include <queue>
using namespace std;

int sample[10006], dp[10005][503];

int main(){
#ifdef TEST
freopen("test.txt", "r", stdin);
#endif // TEST

    int n, m;
    while(cin >> n >> m){
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++)
            scanf("%d", &sample[i]);
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= m; j++){
                dp[i][j] = dp[i-1][j-1] + sample[i];
            }
            dp[i][0] = dp[i-1][0];
            for(int k = 1; k < i && k <= m; k++)//注意k<=m的條件。如不加以限制會超時。
                dp[i][0] = max(dp[i][0], dp[i-k][k]);
        }
        cout << dp[n][0] << endl;
    }

    return 0;
}
發佈了68 篇原創文章 · 獲贊 7 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章