HDOJ Robberies

 

Robberies

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

Source

IDI Open 2009
做這題好糾結的,用上面的數據測試怎麼老是第一個數據輸出3,害我檢查了N遍,但都是一樣的結果,我去提交竟然是AC,我就懷疑是不是OJ的數據太弱了,明明連第一組數據都通不過,哎,後來實在火了,把devc++關了,下了幾盤軍棋後打開又重新運行一下竟然可以了,原來是devc++出錯了。鬱悶

//把銀行所有的錢作爲一個揹包
//狀態方程是  bag[v]=max(bag[v],bag[v-value[i]]*(1-caught_rate[i]) )
//必須保證上次成功逃脫,所有要乘上次逃脫的概率
//bag[v] 表示 robber 偷了v塊大洋後逃脫的最大概率 
#include<iostream>
#include<cstring>
using namespace std;
double caught_rate[101],p,bag[10010]; //被抓的概率,要求總概率不超過p,
int value[101],sum;
int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
         memset(bag,0,sizeof(bag));
         bag[0]=1; //什麼都不偷那麼逃脫的概率是1
         sum=0; //所有銀行的總值
         scanf("%lf%d",&p,&n);
         for(int i=1;i<=n;i++){
               scanf("%d%lf",&value[i],&caught_rate[i]);
               sum+=value[i];              
         }
         for(int i=1;i<=n;i++)
              for(int v=sum;v>=value[i];v--)
                   bag[v]=max(bag[v],bag[v-value[i]]*(1-caught_rate[i]) );
         int i;
         for( i=sum;i>0;i--)
                 if(bag[i]>=(1-p))                 
                       break;
         printf("%d\n",i);
    }  
   // system("pause");
    return 0;
}

 

 
 
發佈了75 篇原創文章 · 獲贊 14 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章