HDOJ 2602 Bone Collector 【0 1揹包】

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41879    Accepted Submission(s): 17418


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
題目鏈接:HDOJ 2602 Bone Collector 【0 1揹包】

    0 1 揹包問題    模板

已AC代碼:

#include<cstdio>
#include<cstring>
#define M 1100
#define Max(x,y) (x>y?x:y)

int dp[M],val[M],vol[M];//val價值,vol體積 

int main()
{
	int T,n,V,i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&V);
		
		memset(dp,0,sizeof(dp));
		memset(val,0,sizeof(val));
		memset(vol,0,sizeof(vol));
		
		for(i=0;i<n;++i)
			scanf("%d",&val[i]);//價值 
		for(i=0;i<n;++i)
			scanf("%d",&vol[i]);//體積 
		
		for(i=0;i<n;++i)
			for(j=V;j>=vol[i];--j)
				dp[j]=Max(dp[j],dp[j-vol[i]]+val[i]);
		
		printf("%d\n",dp[V]);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章