HDU 2.1.2 How many prime numbers

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8122 Accepted Submission(s): 2619
 
Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.
 
Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 
Output

            For each case, print the number of prime numbers you have found out.
 
Sample Input
3
2 3 4
 
Sample Output
2
 

OJ上用pow(x,0.5)會導致complier error

sqrt需要把參數轉換爲double,不然也會出錯


菜鳥級的原創代碼,已AC。若有可提高之處歡迎指導

#include<stdio.h>
#include<math.h>
bool isPrime(int x)
{
	if (x == 2)return true;
	int i = sqrt((double)x)+1;
	while (--i>1)
	if (x%i == 0)return false;
	return true;
}
int main()
{
	int n,total,temp;
	while (scanf("%d", &n) == 1)
	{
		total = 0;
		while (n--)
		{
			scanf("%d", &temp);
			if (isPrime(temp))
				total++;
		}
		printf("%d\n", total); 
	}
	return 0;
}


發佈了48 篇原創文章 · 獲贊 3 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章