Max Factor (hdu_2710) 素數篩選

Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6322    Accepted Submission(s): 2077


Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
 

Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line
 

Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
 

Sample Input
4 36 38 40 42
 

Sample Output
38

題目大意:給出多個數,問哪個數的最大素因子最大;

解題思路:先打表,篩出個素數,再用篩素數的思路求各個數的最大素因子;

代碼如下:

#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;
const int maxn = 20005;

int factor[maxn];
int isprime[maxn];

void Eratosthenes(){
	memset(isprime, true, sizeof isprime);
	isprime[1] = true;
	for(int i = 2;i*i <= maxn;i ++){
		if(!isprime[i]) continue;
		for(int j = i<<1;j < maxn;j += i)
			isprime[j] = false;
	}
}

void MaxFactor(){ //產生各個數的最大素因子 
	Eratosthenes();
	for(int i = 1;i < maxn;i ++)
		if(isprime[i]){
			for(int j = i;j < maxn;j += i)
				factor[j] = i;
		}
	/*for(int i = 0;i < 100;i ++)
		printf("%d %d\n", i, factor[i]);*/
}

int main(){
	int n, t, max_factor, max_num;
	MaxFactor(); //打表 
	while(scanf("%d", &n) != EOF){
		max_factor = 0; 
		while(n --){
			scanf("%d", &t);
			if(max_factor  < factor[t]){
				max_factor = factor[t];
				max_num = t;
			} 
		}
		printf("%d\n", max_num);
	}
	return 0;
} 


 
發佈了95 篇原創文章 · 獲贊 1 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章