Equations(HDU_1496) hash

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7420    Accepted Submission(s): 3048


Problem Description
Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
1 2 3 -4 1 1 1 1
 

Sample Output
39088 0
 
題目大意:問a*x1^2+b*x2^2+c*x3^2+d*x4^2=0有多少個解,其中x在[-100,1]U[1,100],且x爲正數;

解題思路:hash

#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;

int const maxn = 1000005;

int hash1[maxn]; //正數 
int hash2[maxn]; //負數 

int main(){
	int a, b, c, d, t;
	while(scanf("%d%d%d%d", &a, &b, &c, &d) != EOF){
		if((a>0 && b>0 && c>0 && d>0) || (a<0 && b<0 && c<0 && d<0)){
			printf("0\n");
			continue;
		}
		memset(hash1, 0, sizeof hash1);
		memset(hash2, 0, sizeof hash2);
		for(int i = 1;i <= 100;i ++)
			for(int j = 1;j <= 100;j ++){
				t = a*i*i + b*j*j;
				if(t >= 0) hash1[t] ++;
				else hash2[-t] ++;
			}
		int ans = 0;
		for(int i = 1;i <= 100;i ++)
			for(int j = 1;j <= 100;j ++){
				t = c*i*i + d*j*j;
				if(t > 0) ans += hash2[t];
				else ans += hash1[-t];
			}
		printf("%d\n", ans*16);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章