Ignatius and the Princess III (HDU_1028) 母函數 + 整數拆分


Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17692    Accepted Submission(s): 12403


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627



題目大意:給出一個整數n,將他拆分成1-n的整數,問有多少種組合數;


解題思路:母函數;指數爲 數值,用數組下標表示;係數爲方案數,用數組存的值表示;不過,也可以用完全揹包來做;


代碼如下:


#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;
const int  maxn = 120;

int num[maxn + 1];
int c1[maxn + 1], c2[maxn + 1];

int main(){
	int n;
	while(scanf("%d", &n) != EOF){
		for(int i = 1;i <= n;i ++)
			num[i] = n / i;
		memset(c1, 0, sizeof c1);
		memset(c2, 0, sizeof c2);
		for(int i = 0;i <= num[1];i ++)
			c1[i] = 1;
		for(int i = 2;i <= n;i ++){		//共有26個多項式 
			for(int j = 0;j <= maxn;j ++){	//共有maxn+1項 
				for(int k = 0;k <= num[i] && j + k*i <= maxn;k ++)
					c2[j + k*i] += c1[j];
			}
			for(int j = 0;j <= maxn;j ++){
				c1[j] = c2[j];
				c2[j] = 0;
			}
		}			
		printf("%d\n",c1[n]);
	}
	return 0;
}


發佈了95 篇原創文章 · 獲贊 1 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章