hdu4576Robot

Robot

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 1783    Accepted Submission(s): 655


Problem Description
Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise.



At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.
Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).
Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.  
The input end with n=0,m=0,l=0,r=0. You should not process this test case.
 

Output
For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.
 

Sample Input
3 1 1 2 1 5 2 4 4 1 2 0 0 0 0
 

Sample Output
0.5000 0.2500
 

Source
 

Statistic | Submit | Discuss | Note
 


做這道題時我很無語,因爲是挑一道最簡單的題來做,但是自己真的很菜,很水!!

明知道這道題是水題都是在看到人家的結題報告才知道這是概率dp。

對自己的水平很失望。。

還有我看到dp的循環次數時以爲會超時(一百萬*2*200)這樣都不超時,Orz~~Orz~~Orz~~Orz~~Orz!!

用b數組代表是這個狀態,a數組代表是上一個狀態 然後有

b[(j-w+n)%n]+= a[j]*0.5;
b[(j+w)%n]+= a[j]*0.5;


#include<cstdio>
#include<cstring>
double a[212],b[212];
int main()
{
    int n,m,l,r,w,j;
    double va;
    while(scanf("%d%d%d%d",&n,&m,&l,&r))
    {
        if(n+m+l+r==0)
        break;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        a[0] = 1.0;
        for(int i=0;i<m;i++)
        {
            scanf("%d",&w);
            for(j=0;j<n;j++)
            {
                if(a[j]>0)//記住一定要這個剪枝,不然就很容易超時 
                {
                va = a[j]*0.5;
                b[(j-w+n)%n]+= va;
                b[(j+w)%n]+= va;
                }    
            }  
            for(j=0;j<n;j++)
            {
                a[j] = b[j];
                b[j] = 0;   //還有救市這個一定要初始化爲0,不然就會錯。 
            }      
            
        }    
        l--;
        r--;
        double ans = 0.0;
        for(;l<=r;l++)
        ans+=a[l];
        printf("%0.4f\n",ans);
    }    
    return 0;
}    




發佈了58 篇原創文章 · 獲贊 89 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章