EASY_PAT_ZJU_ADVANCED LEVEL_1011 儘量用Vector代替Array,這樣會方便很多

1011. World Cup Betting (20)

時間限制
400 ms
內存限制
32000 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
T T W 37.98
/**********************************************88
	
	@ AUTHOR	:GAOMINQUAN
	@ HARD		:EASY *
	@ MAIL		:[email protected]
	@ DATA		:2014-2-24

/*************************************************/


#include<iostream>
#include<vector>

using namespace std;

const int NUM = 3;
struct lottery{
	
	char resultName;
	double biggestOdds;
	int indexMax;

	lottery(vector<double> args){
		this->biggestOdds = 0;
		this->indexMax = 0;
		for(int aI = 0; aI < args.size(); aI++){
			if(args[aI]>biggestOdds){
				this->biggestOdds = args[aI];
				this->indexMax = aI;
			}
		}
	}

	double getChooseOdds(){
		return this->biggestOdds;
	}
};

int main(){

	double profit = 0;
	double totalOdds = 1;
	char resultName[]= {'W','T','L'};

	for(int i = 0; i<NUM; i++){	

		vector<double> oddsVec(NUM,0);
		cin>>oddsVec[0]>>oddsVec[1]>>oddsVec[2];
		lottery lt(oddsVec);
		totalOdds *= lt.getChooseOdds();
		cout<<resultName[lt.indexMax]<<" ";

	}
	profit = (totalOdds*0.65-1)*2;
	
	printf("%.2f",profit);

	return 0;
}
	


發佈了40 篇原創文章 · 獲贊 3 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章