hdu1028 Ignatius and the Princess III(DP整數劃分)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15663    Accepted Submission(s): 11042


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 

題意:給定一個整數,將其寫成若干個整數的和,求有多少種情況。

可以直接考慮各個加數遞減的情況,避免重複。依舊是DP的思想。

將整數n劃分成兩個整數之和,n+0,(n-1)+1,(n-2)+2,……,(n-n/2)+(n/2)。再將加號前面的加數繼續如此劃分,注意:繼續劃分時,後一個加數至少爲上一級的後一個加數,以確保加數列的遞減性。用a[n][1]表示將n表示成(n-1)+1的情況數,則可知a[n][1]=a[n-1][0]+a[n-1][1]+a[n-1][2]+……+a[n-1][(n-1)/2]+1

a[i][j]=a[i-1][0]+a[i-1][j]+a[i-1][j+1]+……+a[i-1][(i-1)/2]。把a[i][0]都初始化爲1,表示不劃分時就一種情況。最後,將所有a[i][j]都加到a[i][0]上,表示i的所有劃分情況數。

#include <cstdio>
#include <iostream>
#include <algorithm>

using namespace std;

int a[125][70];//a[i][j]表示和爲i 且 兩個加數的後一個爲j的情況數量(j<=i/2)

void biao()
{
    for(int i = 0; i < 125; i++)
    {
        a[i][0]=1;
        for(int j = 1; j <= i / 2; j++)
        {
            for(int k = j; k <= (i - j) / 2; k++)
                a[i][j] += a[i-j][k];
            a[i][j]++;
            a[i][0] += a[i][j];
        }
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    biao();
    int n;
    while (scanf("%d",&n)!=EOF)
    {
        printf("%d\n",a[n][0]);
    }
}


發佈了39 篇原創文章 · 獲贊 1 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章